159 Running Lumpy - Page 2 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: -
AO Member
Join Date: Sep 2006
Location: Nottingham
Posts: 63
Re: 159 Running Lumpy

I found altering my driving style slightly to keep the revs in the 'sweet spot' helped.

Thankfully I am begining to notice this minor fault less and less.
Tricky159 is offline  
Sponsored Links
(Post Link) post #27 of 28 Old 30-07-07 Thread Starter
Status: -
AO Member
Gareth Wigdahl's Avatar
Join Date: Aug 2006
Location: York
Posts: 12
Re: 159 Running Lumpy

Me again
Problem is back and even worse- steering went off as well until I fitted 2 new front tyres. Fine now.
Anyhow, the car still jerks badly at 2000 revs. Dealer has confirmed that it is a known fault and they are writing new mapping software to sort the problem. Will keep you informed.
Gareth Wigdahl is offline  
Status: -
AO Member
AlfaBar1's Avatar
Join Date: Jan 2009
Location: United Kingdom
County: Worcestershire
Posts: 55
Ref. earlier point 'it wouldn't happen with a Honda'. I had an Accord diesel that broke down 3 times in two weeks. Dealer traced this down to faulty fuel pump (1,400 job). Car was still under warranty, Honda didn't want to know. I ended rejecting the car. Alfa Romeo's are no worse than any other make.

Gareth, I'm glad the car is now sorted.
AlfaBar1 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159 , lumpy , running

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome