159 sim card problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 16-12-13 Thread Starter
Status: -
Join Date: Dec 2013
Location: Finland
County: Lansi-Suomen Laani
Posts: 1
159 sim card problem

What you think what would be the reason to "sim card missing or wrong inserted" problem? I got new sim card from operator and it's working on phone but not in the car. Losing my mind with that Sim card slot have little button, it is stuck and i have to take that sim card tray away with little screw driver...
OskuA is offline  
Sponsored Links
Status: Now just the 147..
AO Silver Member
lovelyred159's Avatar
Join Date: Sep 2004
Location: United Kingdom
County: Somerset
Posts: 1,949
Images: 11

Member car:

147 1.6 Lusso


You may get a larger response if you post here:ICE & Blue&Me - Alfa Romeo Forum
lovelyred159 is offline  
Status: -
AO Silver Member
Join Date: Feb 2005
Location: United Kingdom
County: West Sussex
Posts: 1,271
Have you put the SIM card in the wrong way around? I did this and also had trouble ejecting it afterwards.

Last edited by Muz; 17-12-13 at 05:56.
Muz is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159 , card , problem , sim

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome