Alfa 159 2.4 Diesel playing up - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 08-10-13 Thread Starter
Status: -
Mario_S's Avatar
Join Date: Oct 2012
Location: United Kingdom
County: Greater London
Posts: 4

Member car:


Help Alfa 159 2.4 Diesel playing up

Hi all,

I've had my Alfa 159 2.4 JTDM for 3 years now and love it to bits.
Unfortunately, I'm thinking of changing it at the end of the year because my mechanic doesn't seem to know how to fix it when things go wrong.

My choice is to either find a new mechanic in my area who knows about these quirky issues or to get another car. I would prefer to get the car to its former glory and continue to drive this fine specimen of a car.

The problem I am facing is that it keeps losing power. Firstly, my mechanic's diagnostics computer said it was the mass air flow sensor that needs changing. This was changed and it sorted the issue temporarily. Next time it was the EGR valve. This was changed but still didn't resolve the issue.

What I'm still experiencing is occasional loss of power. At times, the "check engine light" goes out but the revs still jump and the car shakes a little when idle. When driving, all is great until a certain point where pressing the accelerator gets me no where and the only remedy to this is to stop the car, turn it off and start it again.

I'm now at a point where I'm really frustrated and want this sorted once and for all. I'm worried that going to an Alfa dealer will cost me an arm and a leg.

Can anyone help me figure out what the issue is? Also, does anyone know of a good AR mechanic in the SW16 area?

Mario_S is offline  
Sponsored Links
Status: 159 Cruiser and Guilietta pocket rocket
AO Silver Member
giblets46's Avatar
Join Date: Jul 2012
Location: United Kingdom
County: Warwickshire
Posts: 4,202
The EGR and the MAF tend to go around the same time (mine did), so no great surprise. Generic MAFs often don't work properly (get the official Bosch one).
Did he replace the EGR or simply clean it? If the solenoid was coroded, cleaning will do very little (and many use reconditioned EGR's that seem to fail quickly). I would try blanking the EGR with a bit of metal from a coke can, see if that resolves the issue.

If the EML is coming on you will have a code (what is it?)

I would also advise cleaning the MAP sensor (with a faulty EGR it will be covered in gunk with means it will be slow to follow manifold pressure, as this is a simple job ( but should not cause the big issues you are suffering).

Also check this guide

One thing that I will add to that list is that the no3 injector on 1.9JTDM and the no1 injector on the 2.4 seem to suffer from corrosion on the plugs that cause poor idle and misfires.

159 1.9JTDM Ti and Giulietta 2.0 Veloce
ex: Punto 55s, Golf Mk5 1.4FSi, A3 (8P) Sportback 2.0TDi SE, A4 (B8) 2.0TDI S-Line, 306 HDI Meridian
giblets46 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159 , alfa , diesel , playing

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome