Change PAS fluid or not? AR159 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 02-10-13 Thread Starter
Status: -
Join Date: Feb 2007
Posts: 1

Member car:

156 2.0ts 2001

Change PAS fluid or not? AR159


I have a 159 sw 1,9 jtdm 2007 wich recently developed the famous steering groan.
Ive read about the reservoir problem and im confident thats where my problem is.

The car has done 170.000km (105.000 miles) and has red/brown fluid in.
The general solution seems to be changing the reservoir and at the same time change to the synthetic green type fluid.
However, ive also read that some people have had immediate failure of the rack seals after changing to the thinner fluid on cars with high milage.

Ive had no problems with leakage, or for that matter any type of steering related issues until now. This sound started over night....

Should i just change the reservoir and top up with red fluid, or go for the full change to green?
Has anyone here experienced problems after changing type of fluid?

Uppsala, Sweden
tampe is offline  
Sponsored Links
Status: -
AO Silver Member
Join Date: Feb 2005
Location: United Kingdom
County: West Sussex
Posts: 1,271
I changed mine on a 2007 SW and within 8000 Kms at a mileage of 145,000 Kms my steering rack started leaking. I have no idea if this is connected and at no stage did I have any groans or problems, even when the rack started leaking. I only noticed because I had oily deposits on the rear of the wheel liner.
Muz is offline  
Status: 16Italiancylinders(V 6,N4,L2,V2,V2)+1Span ish
AO Silver Member
swq4's Avatar
Join Date: Apr 2011
Location: United Kingdom
County: East Riding of Yorkshire
Posts: 1,508
Images: 28
My suggestion is change the reservoir if it is failing (bubbles out top).
In any case, completely empty the system of the old oil.
Given the mileage you could then try new GI, if the groan goes away all well and good.
If not you have the option of trying the GI/R.
swq4 is offline  
Status: mit Schaltwippen und Brera Frontschurze
AO Member
notapkram's Avatar
Join Date: Nov 2007
Location: United Kingdom
County: Greater London
Posts: 72
I had the groan (and vibrations through the steering wheel) on by '57 plate 2.4ti. At the end of last year I asked the local AR service centre (who were maintaining it was the steering rack at fault) to replace both the reservoir (which ARUK agreed to meet the costs of as I had kept it in the network from new) and the red fluid to the green GI/R fluid.
Stupidly, I took it on face value that they had refilled with the green fluid, and did not bother looking under the bonnet. I noticed an immediate improvement, but after about 4-6 months the groaning (but not the vibrations) returned. So I popped the bonnet, and discovered the incompetents at the garage had put the dreaded red stuff in again.
Transpires that the sticker under the bonnet on my car stipulates the red fluid, so the garage went against my instructions and filled with the red stuff. I understand from similar posts on this issue that the sticker on later models stipulates using the green stuff.
Now filled with the green stuff as of yesterday, and I can report an immediate improvement. So my experience suggests replacing both the reservoir and the fluid.
notapkram is offline  
Status: Always Looking for tools!
AO Member
Jona's Avatar
Join Date: Aug 2009
Location: United Kingdom
County: Northumberland
Posts: 95
Images: 17
I am in the same position as tampe,

red in reservoir and has been 130k miles now getting big groaning with frothing fluid. (instead of the little whimpers at low speed now and then)

so order new reservoir with the bypass built in, but when it comes I really don't know which fluid to put in?

I have a bottle of comma CHF 11S green but the age of my car 06 and the millage I just know if I fill it with that and my luck it will leak at the steering rack and I cant afford a £600 repair bill.

fill it with dexron II red and I think it will be alright but will it continue to do more damage and groan sometimes as it has the wrong fluid put in by alfa in the first place! (a lot of other manufactures have done the same mind)

would an aftermarket fluid be the answer?

would putting the lighter CHF 11S runny green oil in with a stop leak additive do the trick?

just stay with the red dex 2/3 and live with the occasional groan? edging toward this I think.

any one experienced this what did you do?

any help please!
Jona is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

ar159 , change , fluid , pas

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome