Help! 159 2.4 Power Steering Pump Noise - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 14-08-13 Thread Starter
Status: -
Join Date: Dec 2012
Location: United Kingdom
County: Leicestershire
Posts: 1

Member car:

159 1.9

Help Help! 159 2.4 Power Steering Pump Noise

I was hoping my first post on here would be more up beat, but I do need your guys help in getting to the bottom of this issue.

Long story short, at the end of May I had my first ever accident on a roundabout which has resulted in a large repair job on the front end(panels, radiators, hoses and so on). I got the car back at the beginning of July and among a number of other issues was a whinning noise that changed in pitch with the engine speed/rpm.

I suspected the power steering fluid myself as it seemed to be a redish colour (I've read about the green/red issues on this forum) and the steering seemed to be a bit heavy, especially in the middle, but I put that down to having driven a punto with silly city steering for the 6 weeks the car was at the repairers.

I've since taken the car to Dave at Intaservices, who after driving the car said it could well be the fluid since he found the steering to be very vague in the middle and when stationary he demo-ed the whinning noise changing pitch as he put it on full lock and then off and on again.

The noise is more aparent from in the cabin with the windows up, but under the bonnet you can hear a quiet noise from the pump area.

I've spoken to the repairers again today and got the part number of the fluid put in during the repair work, p/n 15051616. They have also be granted approval from my insurers to replace the pump, but I would rather find out if it was a mistake on their part or accident damage.

So, my questions are:

1 - is 15051616 the red fluid (GI/E) and is it the incorrect stuff?

2 - if so, should I advise them to not fill it with that and what would be the correct part number? (a google search shows 14421616 is the GI/R green stuff, am I right?)

3 - Would putting this fluid (the red stuff) in the system cause this whinning noise, or could it well have been accident related? and does it require the pump to be changed?

As a side note I don't know what fluid was in there before the accident.
Any help is greatly appreciated,
lchallifour is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159 , noise , power , pump , steering

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome