Unable to put Q-tronic into drive - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 04-08-13 Thread Starter
Status: -
Join Date: May 2013
Location: New Zealand
County: Auckland
Posts: 8

Member car:

159 JTS 3.2 Q4

Unable to put Q-tronic into drive

Afternoon all,

Well a couple of months into purchasing a 2008 159 Q4, I have my first problem. Over the last few days when putting the selector into drive, I've noticed that it's actually gone into 1st (manual mode). I then have to flick it across and change manually. I've tried knocking it back and forth a bit and very occasionally I'll get D flashing up, but it won't usually stay there when I release pressure on the lever. The gearbox is actually functioning perfectly, it just won't let me decide in what mode.

Then just today, it's stopped recognising that I've put it into Park and therefore won't release my key. Grrrr!

I'm assuming it's just some switch in the selector which is worn or loose, but I'm loath to go poking around in there before knowing a bit more about what I might encounter. Any ideas folks? If it's something straightforward I'll have a crack at it myself instead of coughing up my hard-earned.
roughage is offline  
Sponsored Links
Status: Powerflex Mk4 - Non Squeak Edition
Club Member
Membro Premio
JabawokJayUK's Avatar
Join Date: Jul 2011
Location: United Kingdom
County: Cambridgeshire
Posts: 3,379
Images: 31
Its not difficult to get into the shifter assembly and have a look and as you say, its just a bunch of switches on a control board.

There is a guide in on of the threads on this forum on how to change the shifter unit to retrofit paddles shifters, so have a search around and you will find it.

My advice is take it apart and clean all the connectors with electrical contact cleaner, make sure nothing (dirt etc) is fouling any contacts and see how it goes from there.

Worst case scenario a new shift gate unit isn't massive money, and I know at least one person in this forum with one spare, as long as you don't have the paddle shifters on your steering wheel!

2008 159 TI 2.4 JTDM QTRONIC
My Car Details______http://www.jabawoki.com/2014/07/07/alfa-159-ti/
Project Halo Wiki____https://projects.jabawoki.com/index.php/Project_Halo_UK
Project Halo Page____https://www.facebook.com/ProjectHaloUK
JabawokJayUK is offline  
(Post Link) post #3 of 3 Old 05-08-13 Thread Starter
Status: -
Join Date: May 2013
Location: New Zealand
County: Auckland
Posts: 8

Member car:

159 JTS 3.2 Q4

Cheers, thanks for the quick response. I'll take a look and see what I can do.
roughage is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159 , drive , put , qtronic , transmission , unable

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome