159 2.2 JTS Misfiring and Check Engine Light - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 22-07-13 Thread Starter
Status: -
AO Member
Join Date: Dec 2005
Location: Wexford, Ireland
Posts: 28
159 2.2 JTS Misfiring and Check Engine Light

My 06 159 2.2 JTS has over 200,000km and now has a Check Engine Light on. From cold, it misfires until revved for a few seconds. It also sounds rough when the timing changes (1500 - 2000 rpm). No loss of power and seems to drive well once going. Local independent says it's likely a head-gasket leaking coolant into cylinders (he can see misfires on cylinders 2 and 3 on startup). The 'rough sound' at timing change happened about 6 months ago too and timing chain was replaced which solved it for a while but it's back.

Any ideas?

tredmond is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159 , check , engine , jts , light , misfiring

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome