Start/Ignition problems with Brera - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 19-07-13 Thread Starter
Status: -
AO Member
Join Date: Jan 2010
Location: I would rather not say
County: -
Posts: 13

Member car:


Start/Ignition problems with Brera

Hi there.

Over the past few weeks, I've had quite sporadic issues with the ignition. Jump in the car to rush my son to school and it starts first 'press' every time, but If we go out for the day I often have to re-press the ignition button several times for the car to start. It will go days without a problem, then all of a sudden I'll have a few days where it happens multiple times during the day - sometimes it takes 2 presses, sometimes 15. All I get is a click of recognition like something is happening, but apart from that dead as a Dodo as if I have a flat battery. Wait a minute and it fires up just fine.


d33m is offline  
Sponsored Links
Status: 159 Cruiser and Guilietta pocket rocket
AO Silver Member
giblets46's Avatar
Join Date: Jul 2012
Location: United Kingdom
County: Warwickshire
Posts: 4,198
Check the ground cable under the battery, can often become loose/fail, also you fail to mention your engine type...

[color=gray]Sent from Free App[/color]
giblets46 is offline  
Status: Minus an Alfa.
AO Silver Member
Pete McK's Avatar
Join Date: Jul 2006
Location: United Kingdom
County: North Yorkshire
Posts: 1,699
If the dashboard goes dark when you press the start button, it could be a clutch / brake pedal switch issue.
Pete McK is offline  
Status: -
AO Gold Member
Join Date: Jul 2006
Posts: 7,178
Try holding down the brake as well as the clutch.
cj romeo is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

brera , problems , start or ignition

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome