Sat Nav problems - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 15-07-13 Thread Starter
Status: AO Member
AO Member
Join Date: Aug 2011
Location: United Kingdom
County: Berkshire
Posts: 61

Member car:

Alfa Brera

Madness Sat Nav problems

Hi everyone,

I own a Brera II which has the factory fitted Navteq sat nav/cd/blueandme. It was replaced from new after about 15 months under warranty. The new replacement unit has now stopped working 22 months since being fitted. Unfortunately, my car is now just over three years old and therefore not under warranty. Any thoughts, advice, similar experiences?
Britince is offline  
Sponsored Links
Status: Now in a 159
AO Member
edition25's Avatar
Join Date: Mar 2008
Location: United Kingdom
County: Wrexham
Posts: 108

Member car:


Wouldnt the Nav unit be covered under a seperate 2year warranty as it was not part of the car?

Im not sure what warranty Alfa give on parts these days

edition25 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

nav , problems , sat

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome