Faulty Clutch Switch stopping the car from starting - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 7 Old 11-07-13 Thread Starter
Status: New at this so handle with care!
AO Member
Phil07813's Avatar
Join Date: Jun 2013
Location: United Kingdom
County: Derbyshire
Posts: 15
Images: 2
Crazed Faulty Clutch Switch stopping the car from starting

Hi There
I wonder if anyone else had suffered from this problem. This morning I got stuck in stationary traffic and a warning light came on advising that the car's security system was not working with a picture of a steering wheel and a key underneath showing on the bottom left of the dash display. I have 2.4 JTDM Brera and, anyway, decided to turn the engine off whilst I waited.
When the traffic began to move again I attempted to start the car with the usual clutch down and press start..........nothing.........totally dead, even all of the dash ignition lights went out.
Checked the battery terminals and they were fine and locked it, then opened it again to see if that would re-set the car but no luck.
Called the AA and when they tested the battery, all fine. Then once he sat in and tried to start it he saw the notice you get when ignition on 'press clutch or brake to start' and pressed the clutch.....nothing again, then pressed the brake on his 2nd attempt and it started!!!
He said it will be the clutch switch and this was the fault.
Anyone else suffered this?

Phil07813 is offline  
Sponsored Links
Status: -
AO Member
GroovyBoovy's Avatar
Join Date: Jan 2011
Location: United Kingdom
County: Durham
Posts: 328
Images: 2
I suffered a similar problem, garage said it was down to lower battery power?

Don't forget that you can start the car if you press the brake pedal instead.
GroovyBoovy is offline  
Status: -
AO Member
Join Date: Apr 2013
Location: United Kingdom
County: Derbyshire
Posts: 29
Yeah I am having similar issue as well except in my case the car wouldn't start unless the clutch was pressed. I had the battery looked at @ halford and it wasn't great so I got a new battery. With the new battery the error disappeared after and I could start the car with the clutch depressed. ( the vehicle protection error has appeared/disappeared though twice since the battery change but no hill holder/vdc errors). My first port of call would be the clutch switch though since it is a cheaper to fix, I just used the opportunity to get a new battery
jpm159 is offline  
Status: Minus an Alfa.
AO Silver Member
Pete McK's Avatar
Join Date: Jul 2006
Location: United Kingdom
County: North Yorkshire
Posts: 1,699
Also check to see that the clutch pedal is coming back up fully when released. They can get a bit sticky and stop the pedal switch operating.
Pete McK is offline  
Status: missing my GTA
AO Silver Member
Join Date: Jan 2009
Location: United Kingdom
County: Lincolnshire
Posts: 1,589
to start the car you can press the clutch or brake pedal.

note that if you press the clutch you can press and release the start button and it will crank until the car starts; however if you use the brake pedal you have to press and hold the start button until the car has started.
Artermis is offline  
Status: Bella!
AO Member
Robo159's Avatar
Join Date: Nov 2012
Location: United Kingdom
County: Worcestershire
Posts: 38
....If anyone has had the clutch pedal switch replaced, could they post the art number on here please. I need one for my 159 but the main dealer say they are for left hand drive cars only???

As Coxy has said in a previous post 'carnt see them making them left/right hand drive specific' but just want to be sure.

Robo159 is offline  
Status: -
AO Member
jasondainter's Avatar
Join Date: Dec 2009
Location: Sweden
County: Uppsala
Posts: 151
Hi Rob. Theyre not for left hand drive only, I have a right hand drive and that clutch switch also exists (I would stop using that dealer if I was you!). The part you need is Alfa Romeo 159 Switch or Alfa Romeo 159 1 9 2 2 2 4 Clutch Pedal Switch 2005 On

You can take it apart yourself but you have to take the knee airbag off and fiddle around in there for quite a while, there are instructions in http://www.alfaowner.com/Forum/alfa-...ok-solved.html how to do this.

Guessing you fixed this by now but replacing the switch here should do the job.
jasondainter is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

car , clutch , faulty , starting , stopping , switch

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome