Fuel pressure sensor - coding ?!?! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 04-07-13 Thread Starter
Status: [Too Long]
AO Member
AdamHarvey7's Avatar
Join Date: Aug 2011
Location: United Kingdom
County: Norfolk
Posts: 300
Not Happy Fuel pressure sensor - coding ?!?!

I'm still trying to find out why my car is running really bad and hard to start, black smoke at high revs, hesitant, but midrange seems normal .... so far ive replaced my intake manifold, EGR valve, cleaned the throttle body, fuel system, maf and map sensors ... To no avail and I have no management light to help me out.

I also replaced the fuel pressure sensor on the common rail ... And have just found out via ECU scan this needs to be coded, could this be my elusive problem ??? Will not coding cause this issue as I can't do it till my cable turns up.

Failing this when my new OBD cable kit is delivered ill put scan postings up so we have more detail eg injector corrections, actuator tests, fuel pressure ect.
AdamHarvey7 is offline  
Sponsored Links
Status: [URL
AO Silver Member
Join Date: Oct 2007
Location: United Kingdom
County: Wrexham
Posts: 1,684
not sure about coding?
looking at the fes description
This procedure must be executed in case Rail pressure sensor is replaced. It helps reduce engine noise and comply with the emissions standards.
The following values will be reset to default after executing this procedure:
- Pilot injection quantity correction (according to injector aging)
- Main injection quantity correction (according to Lambda sensor reading)

it looks like some sort of fine tuning internal calibration to align fuel pressure and injected quantities from injectors
id be interested if you can even tell any difference after carrying this out.let us know either way.
sussexa is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

coding , fuel , pressure , sensor

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome