Transmission slipping - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 01-07-13 Thread Starter
Status: -
Join Date: Oct 2011
Location: Australia
County: Victoria
Posts: 9
Transmission slipping

Hi guys has anyone experienced this problem with their 159? I have an 07 2.4 jtd and occasionally the transmission auto seems to slip or rev out like it won't catch the next gear usually happens when shifting from 2nd go third in heavy traffic. Ive had the auto box serviced but still happens occasionally. Please dont tell me I need a new auto. Advise would be greatly appreciated
koruptj is offline  
Sponsored Links
Status: -
AO Gold Member
Join Date: Jul 2006
Posts: 7,178
Did it do this before it was 'serviced'

I would recommend getting a dealer with the correct diagnostics to flush and replace the fluid, as it needs done at a steady temperature and has a bit of a also needs absolutely the correct fluid.

Its quite a common transmission, also used by Toyota (who make it) Mazda, Ford, Volvo, eben if you have a valve body problem, most auto transmission shops are familiar with them.
cj romeo is offline  
(Post Link) post #3 of 5 Old 01-07-13 Thread Starter
Status: -
Join Date: Oct 2011
Location: Australia
County: Victoria
Posts: 9
Yeah it did it before the service then when my mechanic changed the fluid it went away for a while ( bout 6 mnths) now its starting to slip again
koruptj is offline  
Status: -
AO Member
melsaltas's Avatar
Join Date: Jan 2010
Location: Greece
County: Attica
Posts: 133
The correct fluid is Gi-Vi.
I have changed the fluid several times but not the right way.
The last time I changed it the correct way and the slipping went away about 80%.
This is the correct way........
Saab 9-3 automatic transmission, fluid level check / adjust
Everytime I put more fluid than I was supposed to and the trans possibly overheated and slipped a lot.Not sure if I am explaining it right....
melsaltas is offline  
Status: Powerflex Mk4 - Non Squeak Edition
Club Member
Membro Premio
JabawokJayUK's Avatar
Join Date: Jul 2011
Location: United Kingdom
County: Cambridgeshire
Posts: 3,379
Images: 31
This slip happens due to the solenoid that holds one of the 3 clutches sticking 2nd to 3rd is the most common one that sticks for some reason (Clutch C1) !!

Here is some info on the gearbox;

An oil change will indeed improve it, and any good mechanic will have access to the proper guide on how to change it which is very involved!! Autolusso did mine the other day and its much smoother as a result.

I am still trying to find someone that will provide uprated clutch plates for the box so I can put more power through the transmission

2008 159 TI 2.4 JTDM QTRONIC
My Car Details______
Project Halo Wiki____
Project Halo Page____
JabawokJayUK is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

slipping , transmission

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome