UJ failure destroys propshaft - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 28-06-13 Thread Starter
Status: -
AO Member
Join Date: Mar 2012
Location: United Kingdom
County: Devon
Posts: 21

Member car:

Alfa 159 TI

UJ failure destroys propshaft

Just wanted to post my current experience and how Autolusso came to my rescue...again! Loud knocking on acceleration, local gearbox centre found failure of propshaft, hanging on by a mount. Alfa dealer quoted 2100 with vat for a new part only, I said no but the centre couldn't source one from its suppliers. Phonecall to Dan @ Autolusso, used one in stock, 200+vat with 50+vat to ship. Due to arrive next week, should be fixed by Wed. So chuffed, but haven't heard of another similar propshaft failure?
Awesome Autolusso!
Kdwilliams is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

destroys , failure , propshaft

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome