Parking sensors/Glow plugs. - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 09-04-13 Thread Starter
Status: 3 Alfa's in the house now!
AO Member
Norro's Avatar
Join Date: Sep 2004
Location: Gt.Yarmouth, UK & Angola
Posts: 77
Parking sensors/Glow plugs.

Hi all.
I have a query with my 2.4 that I wonder if anyone else has had an experience with.
My parking sensor(s) have stopped working, and also my glow plugs have also.
The car starts fine whatever the temperature.
I have noticed however that if the engine is warm/hot, the parking sensors work normally!
Even in the Summer, they worked OK, but as soon as it's got colder and the glow plugs are required, the parking sensors have stopped working unti the engine is really warmed up.
Has anyone else experienced this??

Norro is offline  
Sponsored Links
Status: -
Join Date: Jan 2011
Location: United Kingdom
County: Surrey
Posts: 4

Member car:


My parking sensors only work in the very cold weather! Also my dash display gets brighter then dimmer as you drive?
Alfa 9 is offline  
Status: 5 niggles to go...
AO Member
Brera_Matt's Avatar
Join Date: Feb 2012
Location: United Kingdom
County: Gloucestershire
Posts: 328

Member car:

Brera 2.2 SV "S"

My parking sensor was really flaky too, I swore blind it only worked properly when in the shade! It wasn't bothering me too much but when I took it in for a service I told them about it and asked for an ECU scan.

They identified that it was just the one sensor not working, so I got it replaced and it's been sound ever since.

If you say where you're living, I'm sure someone could recommend a decent indie Alfa garage nearby.
Brera_Matt is offline  
Status: DPF only blocking up space in my garage now!
AO Member
Alfiefreak's Avatar
Join Date: Mar 2007
Location: South Glos
Posts: 656

Member car:

3 series (sorry)

Originally Posted by Alfa 9 View Post
My parking sensors only work in the very cold weather! Also my dash display gets brighter then dimmer as you drive?
That's as it should be
Alfiefreak is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

parking , plugs , sensors or glow

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome