engine management light on my Brera - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 14-03-13 Thread Starter
Status: -
Join Date: Jul 2011
Location: United Kingdom
County: -
Posts: 4

Member car:

Alfa Brera

engine management light on my Brera

Hi Alfa club members,

I have a 2008 3.2 Brera Petrol.

In the last 6 months when I am driving 60-70mph, the injection system light flashes for 10 seconds then goes out again.

It doesn’t happens all the time, and I could be driving for 2 miles or 100miles before its flashes.

Has anyone experience this problem before? Does anyone know what the problem issue is?

mybrera is offline  
Sponsored Links
Status: 16Italiancylinders(V 6,N4,L2,V2,V2)+1Span ish
AO Silver Member
swq4's Avatar
Join Date: Apr 2011
Location: United Kingdom
County: East Riding of Yorkshire
Posts: 1,507
Images: 28
I suggest you get the MultiScan software and ELM Connector
- you will be able to the logged errors
swq4 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

brera , engine , light , management

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome