Random Cruise control switch off - Page 2 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: -
AO Member
althekid's Avatar
Join Date: Apr 2014
County: -
Posts: 12

Member car:

159 Sportwagon

It was from www.shop4parts.co.uk no item code on my confirmation email but listed as "Brake Light Switch (4 pin)
Make & Model: Alfa Romeo 159 1.9 JTDM 16v"

[color=gray]Sent from AutoGuide.com Free App[/color]
althekid is offline  
Sponsored Links
Status: -
AO Member
topman1993's Avatar
Join Date: Jan 2015
Location: United Kingdom
County: Swansea
Posts: 86

Member car:

159 Ti 1.9 JTDM

Reviving a old thread! Been having this problem for a few months, got a copy of multiecuscan and no codes. Only thing I have noticed is that at higher speeds ( possibly over motorway speed limit) the speedo starts to fluctuate. So setting the cruise control over 70-75 just gets deactivated within a few minutes. I'm thinking maybe a speed sensor?
topman1993 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

control , cruise , random , switch

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome