Climate control display disapairing? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 25-01-13 Thread Starter
Status: -
AO Member
Join Date: Mar 2011
Location: United Kingdom
County: Derbyshire
Posts: 44
Crazed Climate control display disapairing?


Very minor issue but seems to happened one or twice a year. always happens on long journey where the display disappears.... and will only come back on when you restart's the engine...

very bizarre... but love that my alfa is able to fix problems by itself... my previous BMW was unable to do that lol
indyheer is offline  
Sponsored Links
Status: 159 Cruiser and Guilietta pocket rocket
AO Silver Member
giblets46's Avatar
Join Date: Jul 2012
Location: United Kingdom
County: Warwickshire
Posts: 4,198
Not really a full solution, but have you tried switching 'Night Panel' on and off again (press and hold the dash dimmer down for 5-10secs, then switch up for 5-10secs), it may re-set it.
giblets46 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

climate , control , disapairing , display

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome