Error messages - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 6 Old 10-01-13 Thread Starter
Status: -
Join Date: Dec 2010
Location: United Kingdom
County: North Ayrshire
Posts: 8

Member car:

Brera 2.4JTDM

Error messages

Been getting a couple of error messages recently on my Brera SV 2.4JTDM 210 - Glow Plug pre heating not available and also Oil Change required. Thought it was odd so had the local garage reset these but within a couple of days both re appeared so reset again and same happened again. So had a look on here and advice said change the plugs and get an oil change even though it had only just had one. So done that and the messages dissapeared for a few days but are now back.
Anyone any ideas on how to get rid of these for good as their annoying me and I am sure there isnt anything actually wrong.
dmanson79 is offline  
Sponsored Links
Status: Squadra Massimo tuned (NL)
AO Member
Join Date: Mar 2012
Location: Netherlands
County: Noord Brabant
Posts: 30
Resetting the error does not help for the oil change warning. This must be done by a service interval reset.

And for the glowplug error, most likely either one of the glowplugs is defective of the relais stopped working.
HeMaN is offline  
Status: -
AO Member
Join Date: Jan 2013
Location: United Kingdom
County: -
Posts: 72

Member car:


I had the exact same glow plug warning on my 159 and it was an easy fix. The main glow plug fuse had gone. A garage fixed it quickly and the warning went instantly and hasn't come back.
Tayo is offline  
Status: Powerflex Mk4 - Non Squeak Edition
Club Member
Membro Premio
JabawokJayUK's Avatar
Join Date: Jul 2011
Location: United Kingdom
County: Cambridgeshire
Posts: 3,379
Images: 31
Random error messages are common when your battery is low on charge and when it's cold your battery is more prone to loose charge quicker, especially if its a few years old. You might want to pop into a halfords and get them to do a free test to see what condition it's in.

Plenty of threads on here about random errors linked to batteries on the way out. Worth a quick check before you start diagnosing faults.
JabawokJayUK is offline  
Status: Loving My 159
AO Member
michaeld's Avatar
Join Date: Sep 2004
Posts: 654
Images: 5
Glow plug - measure the resistance of each one and replace any that are open circuit.
michaeld is offline  
(Post Link) post #6 of 6 Old 14-01-13 Thread Starter
Status: -
Join Date: Dec 2010
Location: United Kingdom
County: North Ayrshire
Posts: 8

Member car:

Brera 2.4JTDM

Thanks for all the messages will give them all a shot and hopefully all my problems will disappear.
dmanson79 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

error , messages

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome