Strange Noise on 159ti - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 06-01-13 Thread Starter
Status: -
AO Member
Join Date: Jan 2012
Location: United Kingdom
County: Merseyside
Posts: 18

Member car:

159 Ti 170

Strange Noise on 159ti


Help needed, got a strange whirring noise when accelerating especially when cold, recedes when foot is taken of accelerator.

The noise reminds me from years ago when the car radio picked up interference and would rise and fall when accelerating

Any suggestions - car is only 18 months old with 15k on clock
Banksy is offline  
Sponsored Links
Status: Alfabook 4400+
Club Member
Membro Premio
SCGT's Avatar
Join Date: May 2012
Location: United Kingdom
County: West Dunbartonshire
Posts: 7,266
Images: 44
Most likely the impeller , as far as I am aware it's normal and nothing to worry about. My GT does it every morning..might even have a chipped fin which makes it whine..
SCGT is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159ti , noise , strange

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome