2 years with a 2.4 159 ti Quatronic. - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 05-11-12 Thread Starter
Status: happier today
AO Silver Member
merlin's Avatar
Join Date: Jun 2006
Location: Kent
Posts: 2,437
2 years with a 2.4 159 ti Quatronic.

Having now had my ti for 2 years I thought that I would share my experience with you.

In that time I have covered 24k miles, I had to have the front wheel camber changed because of excessive tyre wear and changed all tyres to Accellera's and put pressure up to 40psi all round. When i took the car in for it's annual service the front tread was 5mm across both tyres and the rear were 6mm across both which I thought was pretty good still got plenty of wear even after 6 months.

Apart from new wheel bearings on the front off side, new heater hose and slight problem with the gear selector which refused to go into park when I was in a car park in Lincoln must tell you the story of that......................

Stopped in this car park put the car into park, when I got back to it the selector refused to budge from park so I rang Northgate and spoke to Adrain Pile their head mechanic who gave me these instructions................turn off engine and restart hit selector on top with flat of hand and then move it to neutral and hit it again with the flat of the hand it should now go into park which it did without any problems and was was now moving throughout its range without catching. If it should stick again repeat procedure. This happened several time over the weekend and following his advice we arrived home without any further problems.

Apparently this can be caused by the actuation switch on the brake peddle becoming loose or the selector rising up in its seating which a blow with the flat of the hand helps to cure by knocking it down again.

Apart from those problems it has been a pleasure to own and drive.


Forewarned is Forearmed. No1 GRP Maidstone ROC Old Observers never die - they only lose the plot!
merlin is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159 , quatronic , years

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome