engine revs high - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 25-10-12 Thread Starter
Status: -
Join Date: Jun 2012
Location: United Kingdom
County: Lincolnshire
Posts: 4

Member car:

brera 3.2 v6

Help engine revs high

Hi everyone this is my 1st post.I have a 2006 brera V6 Q4 which has been running a dream,but now when I start from cold the engine revs very high for a moment when I depress the clutch (no foot on gas pedal )once warm it's fine.Any ideas please.:
KCS Dogman is offline  
Sponsored Links
Status: -
AO Member
Arpa's Avatar
Join Date: Feb 2011
Location: United Kingdom
County: Suffolk
Posts: 161
Images: 4

Member car:

Brera 3.2 Q4 SV

Does this happen when you are moving? For instance, if I'm trundling along in mine just after starting, using the engine torque to pull me along without any accelerator input, if I then depress the clutch, the engine revs will rise as the load on the engine is released.

This typically only happens when cold and the engine is still 'on choke' with the ecu putting a richer fuel mix in (hence the power to move without accelerator input). The engine also sounds pretty fruity and tends to be hesistant.

Do the revs quickly fall back after initially rising up to about 2k?

Both my engines have done this so presume its pretty normal or is your problem different to the above? Hth
Arpa is offline  
Status: -
AO Member
Harmson206's Avatar
Join Date: Mar 2012
Location: United Kingdom
County: Lincolnshire
Posts: 97
This is normal mine does this when cold
Harmson206 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

engine , high , revs

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome