Disaster! / All Fixed - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 21-10-12 Thread Starter
Status: Alfaless!!
AO Silver Member
phil-gtv6's Avatar
Join Date: Aug 2006
Location: United Kingdom
County: West Sussex
Posts: 3,073

Member car:

E82 125i

Disaster! / All Fixed

Had a bit of a nightmare driving to friend's last Sunday, on M25 then temp warning flashed on and saw gauge had shot up to 130c, lots of steam from the bonnet !

Had to wait a short time until the hard shoulder appeared then stopped and coolant was pouring onto the ground from somewhere, soon clear that there was none left at all

Bought some RAC cover then waited an age (whilst my wife's relatives were rescued by others ) ), all turned into a bit a a farce and didn't get on the way home for nearly 4 hours!! RAC guy reconed the water pump was a gonner.

Anyway, I'd only had the car a couple of weeks so this was extra annoying, so spoke to Nothgate Alfa in Canterbury (where I got it from) and they were very good, sent someone out on Monday to to pick the car and drop off a Guillietta courtesy car

As expected the waterpump had seized and blown it's seals (car has only doen 24k miles!!), and according to the technician it was massively lucky that the cambelt hadn't moved or broke. So they replaced the pump/cambelt and returned it on Friday - drives just like before which is a huge relief

As an aside, was good to spend some time in the Guillietta 1.4tb, it sounded good, handled reasonably well and rode very well, but didn't feel anywhere near as solid as the 159 + don't think I'll ever be sold on its looks
phil-gtv6 is offline  
Sponsored Links
Status: Drinking too much beer in Munich ;)
Join Date: Feb 2012
Location: I would rather not say
County: -
Posts: 1,576

Member car:


good to hear about such good service from the dealership.
FixitSan is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

disaster , fixed

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome