Brera 3.2 Q4 2006 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 06-10-12 Thread Starter
Status: -
Join Date: Jun 2012
Location: United Kingdom
County: Surrey
Posts: 8

Member car:

Brera 3.2

Brera 3.2 Q4 2006

I have bad judder when pulling away and have been that the bushes have gone on the propshaft. Typically of Alfa I've been told you have to buy a new propshaft. new prop is apparently £1250!

Been looking for one from breakers without success. Anyone else had this problem? Any suggestions?
Dynamik is offline  
Sponsored Links
Status: The Bored, BORED
AO Gold Member
Snokio's Avatar
Join Date: Jul 2005
Location: I would rather not say
County: -
Posts: 6,453
Not heard of this before, out of interest, do you get a bad judder all the time?

I suggest taking it to your nearest Alfa specialist rather than a dealer
Snokio is offline  
Status: Breraless :(
AO Platinum Member
Squadrone Rosso's Avatar
Join Date: Aug 2005
Location: United Kingdom
County: Neath Port Talbot
Posts: 29,893
Images: 45
GTleigh had the same problem with his Q4 Qtronic
Squadrone Rosso is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

2006 , brera , brera or 159 , prop

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome