Glow plugs and poor MPG - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 02-10-12 Thread Starter
Status: -
AO Member
samlcampbell's Avatar
Join Date: May 2006
Location: Ayrshire
Posts: 378
Images: 1
Glow plugs and poor MPG

For a few weeks I have had the glow plugs not working message, but the car had no starting problems. Checked with meter and found the faulty one. Then I noticed a 10 - 15% drop in MPG even on long drives. Replaced all 4 plugs and MPG back to 46 average. I had thought the faulty plug would just mean extra fuel being used till up to temperature, but watching the MPG display it seems extra fuel is used all the time .
samlcampbell is offline  
Sponsored Links
Status: [Too Long]
AO Member
AdamHarvey7's Avatar
Join Date: Aug 2011
Location: United Kingdom
County: Norfolk
Posts: 300
All the glow plug does is provide a burst off heat to the cylinder so when the fuel is injected the heat works like catalyst to make it fire quicker. This will have nothing to do with your reduced mpg ... It's more likely related to egr, dpf ... Especially a drop of 10- 15%.

Also you could try do a battery reset ... Unplug the battery to clear all the driving perameters memory.
AdamHarvey7 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

glow , mpg , plugs , poor

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome