Problem with acceleration, Brera 3,2 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 30-09-12 Thread Starter
Status: -
Join Date: Jul 2009
Location: Finland
County: Etela-Suomen Laani
Posts: 2

Member car:

alfa 166 3,0

Problem with acceleration, Brera 3,2


I have problem with my Brera and I dont have a clue what to do..

When I accelerate (with gears 2-6) motor revs drop between 2000-4000rpm, and after that drop, acceleration continues normally. Where should I look for problem?

I was at dealer and they did not found anything faultcodes with their tester.
Only faultcode was airmassflowmeter, and I have a new meter now.
Mipo is offline  
Sponsored Links
Status: -
AO Member
marcoc's Avatar
Join Date: Sep 2011
Location: United Kingdom
County: Bedfordshire
Posts: 13
Images: 2

Could be one of the ignition coils breaking! My used to judder and misfire slighty under load (2000rpm) engine management light flash briefly then resume normaly, turned out to be one of the igntion coils starting to fail.

Get it checked out!
marcoc is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

acceleration , brera , problem

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome