Window problem on 159 Lusso - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 8 Old 13-09-12 Thread Starter
Status: -
Join Date: Sep 2012
Location: United Kingdom
County: Greater Manchester
Posts: 3
Crazed Window problem on 159 Lusso

Hi everyone,
My son bought a 2007, 159 Lusso from the auctions last night. He fell in love with it the minute he saw it.

He was made up with it but when we went to drive off the site, the drivers window dropped down. Our hearts dropped through the floor.

Can anyone tell me what is likely to be the problem. we haven't got around to taking the panel off yet, it was too dark when we got home.
I haven't been able to sleep for thinking that he might have bought a white elephant instead of a gorgeus looking Lusso.

Obviously the first thing is the door panel, is it easily removed?
If it's a motor or runners problem, are they expensive?

Look forward to hearing from you, I'd best try and get some sleep and look at it while he is at work.

Davesmudger89 is offline  
Sponsored Links
Status: Smitten with the Busso
AO Silver Member
Alfadisiac's Avatar
Join Date: Apr 2011
Location: United Kingdom
County: Wrexham
Posts: 1,282
I know an auto electrician who told me that he has done a few 159's that did that. He said its usually the motor.
Get on eBay and have a look...
I'd have a proper look to determine its the motor before buying one though...
Alfadisiac is offline  
Status: -
AO Member
Join Date: Oct 2008
Location: United Kingdom
County: Highlands
Posts: 355
Had this problem recently it turned out there was a problem with the window regulator one and a half hrs work under warranty hope this helps.
kinloch4 is offline  
Status: 159 SW Ti Sold :( RS4 Avant Bought :)
AO Member
Phil_D's Avatar
Join Date: Jun 2005
Location: United Kingdom
County: -
Posts: 412
Images: 50

Member car:

159 SW 3.2 Q4 Ti

Replaced my rear window motor myself, fairly easy job, part from Alfa romeo cost 95 inc vat...
Phil_D is offline  
(Post Link) post #5 of 8 Old 14-09-12 Thread Starter
Status: -
Join Date: Sep 2012
Location: United Kingdom
County: Greater Manchester
Posts: 3
Hi Guys,
I stripped down the window panel, part way, something was stopping me from taking the main steel plate completely out.
I removed the two pieces of wood that had held the window up when we bought the car from the auction.......grrrrrrrrrrr.
I found that a cable had corroded and snapped........why had it corroded in one spot?
I tried to buy just the cable, without success, so I bought a regulator for 55 off the internet.
Thanks for your replies, I look forward to reading some further posts...the one on windows IT has already helped me.
Davesmudger89 is offline  
Status: permanently confused
AO Silver Member
Sunbar's Avatar
Join Date: Mar 2003
County: -
Posts: 2,425

Member car:

MINI Cooper

Snapped cables are fairly common due mainly to the small radius pulleys and degree of bending they have to cope with. Not specifically an Alfa problem and common to all makes, early failures do occur but most last over 10 years. There was only one supplier for the cable in Europe, (Kűster Germany) but now more than likely its sourced from China.

Cables on their own are not serviceable. Re-winding the cable-drum without some tooling is a nightmare. So buying a window regulator is the only option.

Last edited by Sunbar; 14-09-12 at 10:05.
Sunbar is offline  
Status: -
Join Date: Sep 2012
Location: United Kingdom
County: Antrim
Posts: 5
Hi guys. And ladies. I am new so please bear with me. Just got my new toy. Q4 3.2. tI. Sw.

The window warning light Amber on the dash cluster ( safety feature not working) rear back window. Is this something I can re set, I know the car had a new battery just 2 weeks ago, could this waning linked ?

The dealer I got the car from cleared this light which came on on the test drive. Was fine all day. If easy to re set I will do it, save me trip back to dealer .
Q4steven is offline  
Status: Flying it!
AO Member
Mushcles's Avatar
Join Date: Aug 2011
Location: Ireland
County: Tipperary
Posts: 606
This is a complete fudge, but that happens the odd time in my Brera. If you press and hold the lock button on your keys the windows will go up. It seems to reset this problem.
Mushcles is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159 , lusso , problem , window

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome