159 fuel flood problem. - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 03-09-12 Thread Starter
Status: Amante
AO Silver Member
NICUS's Avatar
Join Date: Mar 2011
Location: South Africa
County: North West
Posts: 1,542

Member car:

Gt 1600 Junior

159 fuel flood problem.

My uncle has a 159 1.9jts and want's to get the car ready without problems to his wife to sell the jetta4 as a deposit and have two alfa's in the garage.

No fault codes.
Car doesn't start first time round in the morning. If it does it's luck.
If not 3 minutes has to pass. then try and start it again.
Problem is we believe his starter might give in as he "jump starts" the car in gear with the starter.

Possible faults.
High pressure mechanical pump might leak back into engine hence the fuel smell in oil.
Can't be rings as it was already replaced after engine overhaul in 2011.

Any other ideas?

NICUS is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159 , flood , fuel , problem

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome