159 instrument panel illumination - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 01-09-12 Thread Starter
Status: -
AO Member
Join Date: Mar 2005
Posts: 27
159 instrument panel illumination

I wonder if someone can help with this problem I'm having with my 1.9JTDM dashboard. Basically the instrument panel multifunction display (red lcd display) & warning lights at top of panel (indicators, fog lights, hazards) are not displaying on the panel (no lights showing on at all). I have checked all the fuses and they all see to be OK. Has anyone else had these issues.

Hope someone can help.

pbennett is offline  
Sponsored Links
Status: -
AO Member
Join Date: Dec 2007
Posts: 26

Member car:

159 2.4 Q4 Ti SW

I haven't had this out myself but would imagine the instrument cluster is one unit. this means the fault is most likely internal to that unit.
DeBruce is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159 , illumination , instrument , panel

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome