oil pressure gauge saying zero - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 31-07-12 Thread Starter
Status: -
AO Member
Join Date: Mar 2006
Posts: 15
oil pressure gauge saying zero

Set off in the 159 1.9jts this morning looked down at my oil pressure gauge and its at zero,
Only had the car for a few weeks and I've never noticed being on zero before, I drove the car a few miles and it feels ok but didn't drive it to hard just incase, is there something drastically wrong or is it the gauge knackered?
doowe is offline  
Sponsored Links
Status: Now just the 147..
AO Silver Member
lovelyred159's Avatar
Join Date: Sep 2004
Location: United Kingdom
County: Somerset
Posts: 1,949
Images: 11

Member car:

147 1.6 Lusso

Not familiar with the JTS but this thread seems to suggest it is level and not pressure but they are often flaky anyway:
lovelyred159 is offline  
Status: -
AO Member
Layzeedude's Avatar
Join Date: Dec 2012
Location: United Kingdom
County: Warwickshire
Posts: 31

Member car:

V6 Brera

Hi Doowe,

Did you get to the bottom of this? Just bought a Brera and noticed my oil temperature needle never moves off the stop.


Layzeedude is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

gauge , oil , pressure

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome