159 2.2 selespeed gearbox issues - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 25-06-12 Thread Starter
Status: -
Join Date: Jun 2012
Location: Russian Federation
County: Moscow
Posts: 1

Member car:

159; 2.2

Hmmm 159 2.2 selespeed gearbox issues

Hi guys

Need help with identifying gear box problem on my 2007 159 2.2 baby. Here are the symptoms:

1. it either stops switching gears in automatic mode (manual working fine) OR it would not go from 3rd to 4th at all OR both. The monitor would just blink "have gearbox checked" in red.

2. now the strange thing is that the problem appears and then disappears again which suggests that it is not really a gearbox issue but something else instead I think. sometimes it starts when I start the engine and then goes away after a few miles. Sometimes it just doesnt happen at all. Sometimes I can start my car and drive perfectly for quite some time and then all of a sudden after I drop to 1st it happens again.

First experienced this issue last November. Took it to the local garage specializing on Italian cars. The tests did not identify any problems with gearbox (or anything else) at all. Mechanic just rebooted the system and the problem was gone for 6 months or so, but now I've got it again...(((

I've read through a few threads here but the did not find a matching description (sorry if I was not digging good enough!)

I am driving this car on weekends mainly so got a little less than 20k in almost 5 years (practically new car!). So my call would be to change the accumulator first

What do you think? Any thoughts would be greatly appreciated!
thesaviour is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159 , gearbox , issues , selespeed

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome