Definitive answer to grinding noise when on full lock - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 23-04-12 Thread Starter
Status: -
Join Date: Jan 2011
Location: United Kingdom
County: West Yorkshire
Posts: 7

Member car:


Definitive answer to grinding noise when on full lock


I've checked the forum and there doesn't seem to be a definitive anwer to why, when starting at low speed a grinding/crunching noise is heard from the wheel area when on full lock. Some people suggest steering fluid, others CV joint, or the rack sytem. Even cold weather could cause the problem. I have a 59 plate 2.2 JTS Brera that has done 10K. Is it something I should worry about and act quickly? Would it fall under the warranty? Views much appreciated.


roddism is offline  
Sponsored Links
Status: Soon to be Busso-less again :(
AO Member
losparx's Avatar
Join Date: Jul 2008
Location: United Kingdom
County: Norfolk
Posts: 384
Images: 3

Member car:

GTV 3.0 V6

I have exactly the same problem and would be very interested in some info.
One Alfa mechanic told me its the diff, I struggle to beleive this as it only hapens in the cold and disappears afer a short journey.
CV joint was my thought but apparently they make mroe of a clicking noise ?!?
Wheel bearing?
losparx is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

answer , definitive , full , grinding , lock , noise

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome