Sloshing of water sound at low speeds - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 19-04-12 Thread Starter
Status: -
AO Silver Member
Join Date: Feb 2005
Location: United Kingdom
County: West Sussex
Posts: 1,271
Sloshing of water sound at low speeds

I imagine that the sound is also there at speed but I can only hear it at low speed. Sounds like it is in the door but when I stop and open and close the door the door I can't hear anything. Have yet to find the drain holes to check if they are blocked.

Has anyone else had this? Can't be good for the car wherever this water is trapped. Seems to be rain related as the last time I heard it was after heavy rain and then it just disappeared when it stopped raining.
Muz is offline  
Sponsored Links
Status: -
AO Member
rixf666's Avatar
Join Date: Apr 2011
Location: United Kingdom
County: Greater London
Posts: 709
i had a similar noise on mine recently, it was water in the sill, there should be a drainage plug somewhere on the underside to let it drain out.
rixf666 is offline  
Status: In Alfa heaven!!
AO Member
Join Date: Nov 2010
Location: United Kingdom
County: Argyll and Bute
Posts: 71
i had a similar problem but noticed my drivers footwell was wet, so i looked under the bonnet on the drivers side and noticed the drain hole was blocked and i had about four inches of water.

i drained it and made the drain hole a bit bigger never had the problem since.

Tazman3 is offline  
Status: -
AO Member
Chuffy's Avatar
Join Date: Oct 2009
Location: United Kingdom
County: Cheshire
Posts: 307
Images: 2
I had a simliar noise coming from the rear of the car. I thought it was the fuel tank until I went to change a wheel and discovered that my spare tyre was sitting in 3 inches of water. I have no idea how it got there as there were no damp patches or traces of a leak.
Chuffy is offline  
Status: Skunk'd...
Club Member
Membro Medio
Clogz's Avatar
Club Member Number: 1405
Join Date: Sep 2010
Location: United Kingdom
County: West Yorkshire
Posts: 929
I had something similar on my Shigane... Then noticed one of the rear lights had filled up with water...
Clogz is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

low , sloshing , sound , speeds , water

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome