New to me 159 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 04-04-12 Thread Starter
Status: -
AO Member
Join Date: Sep 2007
Location: Malta
County: Sliema
Posts: 11
New to me 159

I couple of months ago I bought a 2007 159 2.4. The car was bought in the uk, after a year was taken to spain and after 2 years was then brought to Malta all by the same owner.

I plan on going overland with it next week covering around 2k miles and I have a couple of questions.

The has has covered 40k miles.

I plan on doing an oil change before my trip. Am I correct in thinking that I will need 6lts of oil, oil filter, air filter, fuel filter and sump plug washer.

On reading through the forum I have come across various posts on Cam Belt failure. Since the car is now 5 years old, should I replace the cambelt even though it only has 40k miles?

I have noticed a whine that seems to be coming from the right hand side of the engine. Is this a sign of water pump bearing failure?

I will not be able to get the cambelt changed before my trip. I would not like to cancel my trip next week but if I am risking imminent cambelt failure I will have to.


Last edited by austingm; 04-04-12 at 09:49.
austingm is offline  
Sponsored Links
Status: -
AO Member
Join Date: Feb 2011
Location: United Kingdom
County: Cambridgeshire
Posts: 253

Member car:

159 2.4 Lusso

Nice car!

Mine is also a 07 2.4 with 55K miles on the clock.

The cam belt should go on to 70K miles, so you are safe there. The water pump should be replaced at the same time.

As for the whine, I also have the same thing (or it at least sounds like it). I was told that it is something that can't be pinpointed as yet, but it hasn't got any worse, so don't worry too much. I have just done over 1200 miles in a single trip with the car and it was fine. I would get it checked, but maybe not to worry too much as yet......

Other people may have differing and more informed opinions on this. Hope you get a more definitive answer...

johnnyboy114 is offline  
Status: -
AO Silver Member
Join Date: Feb 2005
Location: United Kingdom
County: West Sussex
Posts: 1,271
I'd be worried about the cambelt/water pump after 5 years but I am somewhat paranoid. I even changed my GTV cambelt after 3 years and 12,000 miles. Maybe the diesel cambelts are not as time sensitive as the twins spark ones. Somebody with in depth knowledge will no doubt be along shortly.
Muz is offline  
Status: 159 in progress
AO Member
a2themfk's Avatar
Join Date: Nov 2011
Location: United Kingdom
County: Belfast
Posts: 226
Images: 4

Member car:

Black 159 ti

Im with Muz i'd change the belt and water pump soonish, got my 5 year 159 in Nov last year with 46000 and that was the first thing i did. Id tru a pollen filter @ it also along with the oil and filter you mentioned above, 5 min job done thru the glove box. As for the whine check the hoses coming of the fuel filter, on mine they vibrate esp the one to the fuel pump which in turn causes a very audible whine, cable tie and some foam sorted it.
a2themfk is offline  
(Post Link) post #5 of 5 Old 05-04-12 Thread Starter
Status: -
AO Member
Join Date: Sep 2007
Location: Malta
County: Sliema
Posts: 11
Many thanks for the replies!

I got 6 ltrs of selina, oil filter, air filter, sump washer, fuel filter and pollen filter from the AR dealers.

They insisted that the recommended oil is 5w30. From what I have read on the forum it seems that the general consensus is that for the 2.4 5w40 should be used. I double checked and the Selina website recommends 5w30 (SELENIA WR P.E.) for the 2.4.

Lubrificanti e oli motore Selenia Italia - tblAlfaRomeoAuto
austingm is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome