I think my clutch is dragging. - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 20-03-12 Thread Starter
Status: Ahh, Spring
AO Member
andyp123's Avatar
Join Date: Dec 2010
Location: United Kingdom
County: Leicestershire
Posts: 101
Images: 11

Member car:

159 2.4 JTDM

I think my clutch is dragging.

It started off a little while ago as a problem changing from 1st to 2nd. Itís like the clutch isnít disengaging properly and 2nd only engages with a crunch. Now itís started doing the same from 2nd to 3rd, and when changing down to 3rd from 5th or 4th. Also, when releasing, the clutch engages rather abruptly, quite low in the pedal travel and occasionally, the pedal seems reluctant to come back up fully.

Could this be as simple as topping up the clutch fluid, or is it a potential master cylinder problem? Is that a major (expensive) job?

The car is a í57 2.4JTDm 159 with 40k on the clock. Apart from this, itís running beautifully.

Where there's no speed camera, there's no speed limit!
andyp123 is offline  
Sponsored Links
Status: -
AO Member
Join Date: Jul 2013
County: -
Posts: 32

Member car:

Brera 2.4

I'm sorry to drag up an old thread, but just wondered what the outcome of this was as my 2.4 Brera has the same symptoms :-/

sammyblackbaron is offline  
Status: -
AO Silver Member
Join Date: Mar 2007
Location: Heathrow, UK
Posts: 1,365
Hang on, I don't really understand what he's saying... My pedal also doesn't come up fully but seems to be a very common annoyance!
I saw a thread where a guy stripped down the cowling under the steering wheel and found a big wiring loom wrapped in front of the clutch pedal preventing it from free movement!

And I had a dog of a gear change, no crunching, but a pig to get into first at times and other gears.
New gearbox oil has improved that massively its still nothing like alfa boxes of old but its not an alfa gearbox...
mo 156 is offline  
Status: Busso
AO Silver Member
Join Date: Apr 2012
Location: United Kingdom
County: Berkshire
Posts: 2,548
Bleed the clutch. Symptoms sound like air in the line. Could be a leak as well.
rxe is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

clutch , dragging

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome