159 1.9 JTDm 16v Loss of power - Tried unplugging MAF - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 13-03-12 Thread Starter
Status: Long time listener
AO Member
Join Date: Apr 2008
Posts: 10

Member car:


159 1.9 JTDm 16v Loss of power - Tried unplugging MAF

I've been reading around on the current loss of power I'm experiencing, tried a few things but thought I'd post on here for some answers.

I've had my 159 1.9 JTDm 16v for 2 months now after trading in my 147 1.9 JTD 8v. This morning I experienced a loss of power below 2500 revs, not much at all, then it kicks in and seems normal above that.

I did immediately consider the EGRV as I had an issue with that on the 147, although the symptoms are different in this case. Reading around and chatting to colleagues I tried unplugging the MAF but that didn't change anything performance wise it just put the engine light on (it's still on after plugging it back in but I assume it'll go away after a few clear checks on start up - is this right?).

There were no symptoms other than loss of power this morning, no engine warning light, smoke or MCSF warning.

So next I'm going to look at the pipes to/from the turbo to check for leaks as I could be loosing boost.

Also I'm considering the EGRV, putting in a blanking plate. I did this on the 147, but the symptoms were very different on that, it dumped out lots of smoke and gave the MCSF warning but I didn't loose power.

Anything else to look at?

Cheers guys
craigsmith1977 is offline  
Sponsored Links
Status: Angel tuned tyre burner
AO Silver Member
Alfa.Romeo's Avatar
Join Date: Mar 2009
Location: United Kingdom
County: Kent
Posts: 2,124
Probably egr stuck open and you can't 'just blank it off' as it'll throw a fault code. Also if you add your location to your profile someone can point you to a local specialist
Alfa.Romeo is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159 , 16v , jtdm , loss , maf , power , unplugging

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome