Repeated Engine Light problem? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 13-03-12 Thread Starter
Status: -
AO Member
Join Date: Jun 2011
Location: United Kingdom
County: Essex
Posts: 409
Repeated Engine Light problem?

So it comes on every couple months or so. The car drives fine but I take it in to the dealers. First time it was the Lambda, next time a software upgrade, last time they didn't know so they reset the computer to factory settings, this time it's a wiring issue for which I have to leave it in tomorrow for the day.

What gives?

I've never had any problems with my Alfas before this one. Once thy set it right I just drive around on tenterhooks waiting for the next time.

Has anyone here had any such problem in the past?
miketi is offline  
Sponsored Links
Status: -
Rale Young's Avatar
Join Date: Mar 2012
Location: Malaysia
County: Selangor
Posts: 2
My problem : not only the engine lights come on & off but all the warning lights ie.vehicle protection system, airbag, etc come on & off. Even the air-cond & radio come on & off. The local garage reformated the software & did the software upgrade but these did not solve the problem. I'm still waiting for the solution.
Rale Young is offline  
Status: Drinking too much beer in Munich ;)
Join Date: Feb 2012
Location: I would rather not say
County: -
Posts: 1,576

Member car:


Some of these issues sound like they could be connector related.

Last week i was driving along a bridge with the cruise control on, ad when we hit the bump at the bridge centre span the cruise control went off and I could no longer activate the cruise mode after that, it was as if i didn't have CC.

I repair machines for a living and faults like these become common as machines age. Generally the cure is to reseat all the connector going in between various units and yoiu can improve on that by adding a quick spray of contact cleaner.

The underbonnet area of a car is a hostile place for electrical connectors, and in winter even interior connectors are tested to the max by going from over 25C in direct sunlight to -10C at night and with accompanying humidty/condensation issues.

For problems which are intermittent or which make no sense, it can often be possible to resolve them by working around all the major electronic components, reseating and cleaning the connectors to each one.

FixitSan is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

engine , light , problem , repeated

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome