Squeek/Click/Chirrup Solved - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 12-03-12 Thread Starter
Status: Still engineering
AO Silver Member
Old Engineer's Avatar
Join Date: Mar 2003
Location: Esher
County: Surrey
Posts: 1,927
Images: 12
Squeek/Click/Chirrup Solved

Rather than add this to the other post (which now covers several sources of rattles) I thought I'd add this specific issue.

Mine has had an annoying noise for several weeks. At first I thought it was a relay click as I went over bumps. Then it developed more of a squeek to the harsh click. While driving it sounded like it was in the near side footwell. With a bit of help I narrowed it down to the front passenger door - although holding it made no difference. I found I could get a similar noise (but not the same) by pushing at the top rear corner of the door. The seal there is folded back against the door opening and appears to 'Chirrup' on the paint. I suspect the door is moving as the door opening is being distorted over bumps.

I've applied silicone spray to the inner and outer rubbers and the noise has gone!

Last edited by Old Engineer; 12-03-12 at 21:15. Reason: Spelling
Old Engineer is offline  
Sponsored Links
Status: -
AO Member
Tricolori's Avatar
Join Date: Dec 2011
Location: United Kingdom
County: Staffordshire
Posts: 411
Images: 1
well done old engineer! that exactly the same prob i had!

although i tried to squirt silicone down the back edge of the door pad as i thought it might have been that.

so its def the door seal on the paint? our roads are that bad (and the fact the TI suspension is firm) it squeeks all the time.
Tricolori is offline  
Status: 16Italiancylinders(V 6,N4,L2,V2,V2)+1Span ish
AO Silver Member
swq4's Avatar
Join Date: Apr 2011
Location: United Kingdom
County: East Riding of Yorkshire
Posts: 1,507
Images: 28
Once a month I clean all the door/hatch rubber seals with Autoglym Ruibber Cleaner and then surprise myself for a week with the lack of squeaks. Fortnight later they come back, a week later I remember to repeat the process and hey presto gone again!
swq4 is offline  
Status: Broken again...
Club Member
Membro Premio
GhostyDog's Avatar
Club Member Number: 17
Join Date: Sep 2005
Location: Right Side O The Pennines
County: West Yorkshire
Posts: 25,663
Images: 6
All the squeaks i had in my brera have gone now the weather has warmed up.
GhostyDog is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome