159 2.2 JTS Internal control panel system gone haywire - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 12-03-12 Thread Starter
Status: -
Rale Young's Avatar
Join Date: Mar 2012
Location: Malaysia
County: Selangor
Posts: 2
159 2.2 JTS Internal control panel system gone haywire

Hi, I'm a newbie from Malaysia & have owned my bella for the past 2 years.
The problem I'm facing is that the the radio, air-cond, cabin lights go off and on everytime I drive. Even the dashboard indicators & meters go bonkers. The message I normally get is Vehicle Protection System is not activated & some other stuffs. The local service dealer has had 3 attempts at rectifying it but failed. According to them the last resort would be to change the ECU box in the boot but it'll cost a bomb. Helppp!!
Rale Young is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159 , control , haywire , internal , jts , panel , system

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome