fuelling problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 7 Old 03-02-12 Thread Starter
Status: taxi
AO Member
sleek's Avatar
Join Date: Mar 2011
Location: Australia
County: Victoria
Posts: 101
Images: 24
fuelling problem

no fuel in common rail , fuel at filter pump in tank works, maybe fuel pressure reg faulty ?????
sleek is offline  
Sponsored Links
Status: -
AO Member
Join Date: Jul 2011
Location: Germany
County: SHA
Posts: 219

Member car:

159 1.9 jtdm

Untitled-1.jpgjust a thought .... did you press the fuel cut off switch
Joomoo is offline  
Status: -
AO Silver Member
JON156VELOCE's Avatar
Join Date: Jun 2011
Location: United Kingdom
County: Cardiff
Posts: 2,026
Are you really expecting any help with that title....?
JON156VELOCE is offline  
Status: -
AO Gold Member
Join Date: Jul 2006
Posts: 7,178
Checked the HP pump at the engine ?

Also be aware that diesel injection pressures mean that fuel spayed onto the skin can be fatal as it quickly results in blood poisoning.

Don't fart about with diesel injection systems unless trained.
cj romeo is offline  
Status: funked up
Global Mod Team
paintergirl's Avatar
Join Date: Oct 2006
Location: United Kingdom
County: Dumfries and Galloway
Posts: 9,444
Images: 2
Originally Posted by JON156VELOCE View Post
Are you really expecting any help with that title....?
Funny, I thought that too
paintergirl is offline  
Status: Misunderstood by many....
AO Platinum Member
n13roy's Avatar
Join Date: Feb 2008
Location: South Wales
Posts: 28,466

Member car:

147 JTDm Ti

Yes indeed, not the best title for a thread on advice at all !!!!.........
n13roy is offline  
Status: Breraless :(
AO Platinum Member
Squadrone Rosso's Avatar
Join Date: Aug 2005
Location: United Kingdom
County: Neath Port Talbot
Posts: 29,893
Images: 45
Given our GT issues and the fact that you can't get key parts for a five year old car (a replacement engine, oil coolers & associated pipe work), I'm inclined to agree that manufacturer support is indeed ****!!
Squadrone Rosso is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

alfas , fuelling , problem

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome