2006 Brera 2.4 low revs. problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 29-01-12 Thread Starter
Status: -
AO Member
Join Date: Jan 2011
Location: Portugal
County: Porto
Posts: 157

Member car:

Brera 2.4 JTD

2006 Brera 2.4 low revs. problem

Hello everyone, I have a problem with my Brera, the engine revs very very slowly until around 2000rpm, after that it goes normally, pulls as it was new, but below 2000 it is extremely sluggish, I even had trouble getting out of my garage because the exit ramp is upwards.

I have read many posts about the EGR and swirl valves, but my problem is stranger because It didn't degrade slowly. I went for a drive, everything was ok. I parked the car, and when I went for another drive the problem started as soon as I turned it on, it came suddenly.

Does anyone have an idea of what it could be? My car has 72 000Km, and never gave me any problems, this is my first one and I'm very worried

exar1711 is offline  
Sponsored Links
Status: EGR blocked off - OK now
AO Member
alipet's Avatar
Join Date: Jul 2010
Location: United Kingdom
County: Antrim
Posts: 119

Member car:

Brera 2.4SV

EGR valve.

I've just had the same problem. I removed the EGR valve, cleaned out the masses of soot, and eventually got the solenoid moving freely. I also installed a blanking plate with a hole in it.
The low rev problem seems to be cured (although I think it could still be better), but I now have a "check engine" light. I think this is caused by the blanking plate.
My next plan is to fit a full blanking plate and have the EGR deleted. This will happen on Wednesday. Fingers crossed.
alipet is offline  
Status: -
AO Member
Join Date: Aug 2005
Location: Holbeach
County: Lincolnshire
Posts: 75
Images: 2

Member car:

Alfa 159 2.4 Ti

Agree EGR valve. I have recently had same issue. No degradation in the problem. fine one day then not the next. same symptoms. New EGR valve and the reduced flow plate and back to normal.

Good luck with a fix.
watersd is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

2006 , brera , low , problem , revs

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome