Cam Belt on 159 1.9 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 07-01-12 Thread Starter
Status: -
AO Member
Join Date: May 2011
Location: United Kingdom
County: Cheshire
Posts: 20
Not Happy Cam Belt on 159 1.9

ha all after some assistance i just went to change my cambelt for the first time got ready to remove but just as i used the crank pully bolt to crank engine the belt slipped a few teeth and i am not sure how meany so any ideas how to get timing back in check ???

the belt is a drako belt from alfaworkshop with timing marks on.
turricann is offline  
Sponsored Links
Status: -
AO Silver Member
JON156VELOCE's Avatar
Join Date: Jun 2011
Location: United Kingdom
County: Cardiff
Posts: 2,029
Hi,Did'nt you put your own marks on before removing the old belt..?
I think the crank pulley does have a timing mark on it but that is to line up with the belt mark and not with a corresponding mark on the block as the cam pulley does with a mark on the head but I'm pretty sure that the dowel which locates into the aux belt pulley should be at the 6 o clock (bdc) position when number 1 is at tdc.

As you think it has moved then the only correct way would be to use the proper timing tools which will ensure that the crank is in the correct position.
When I did my belt I remember that the lines on the belt did line up with the marks on the cam and crank when it was in the correct position, the pump pulley doesnt need to be timed.

Are you also changing the tensioner, idler and water pump as it is usually the pump which causes the belts to fail.
JON156VELOCE is online now  
(Post Link) post #3 of 3 Old 08-01-12 Thread Starter
Status: -
AO Member
Join Date: May 2011
Location: United Kingdom
County: Cheshire
Posts: 20
original belt still on, no marks on original belt was moving belt on crank bolt pulley to look for mark when it slipped once i had doe that i was going to mark then remove think ill just buy the tool think its only 50 from the bay yes will be changing all them inc water pump.

Last edited by turricann; 08-01-12 at 12:15.
turricann is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159 , belt , cam

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome