159 Ti Tracking and Clutch problem. - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 29-12-11 Thread Starter
Status: -
AO Member
Tricolori's Avatar
Join Date: Dec 2011
Location: United Kingdom
County: Staffordshire
Posts: 411
Images: 1
159 Ti Tracking and Clutch problem.

Hi all. I have a 58 plate 159 Ti which i love but has a few issues.

Firstly, on the way home after i bought the car i noticed the tracking was out. It pulled to the left slightly. I took it back to Mangoletsi's and they did admit that it was out and re-aligned it.......until i drove it home again and it was STILL pulling to the left!!!!

I take it that this issue is linked heavily with the tire ware issue that the 159's suffer with?? My tires are quite new (think they were changed before i bought the car) so can't tell yet if the inside edges are wearing out. Is this something that they can fix or are people on here finding that the problem won't go away even after the tracking has been sorted? (Again)

Secondly, I have a grinding sensation on my clutch pedal when i get the "bite."
I'm not sure if this is normal for alfas or even the 159's. I am a bit of an alfa newbee.
Could this be the clutch "on it's way out?" I don't ride the clutch so i'm guessing it can't be that.
When i took it to mangoletsi's the first time for the tracking problem, they diagnosed the grinding sensation as Drive Shafts!!! Now, i'm no technician but this is a bit confusing. The car is booked to go back in next week for drive shaft replacement and i'm going to tell them also that the tracking is still out! Is there an issue with driveshafts on the 159's too? The car has only done 46k.

If anyone has had a similar experience then it would be great to know the in's and out's.
I do love my 159 but at the same time i'm hoping that i won't fall out with my dealer.

Ps i forgot to add, i'm only getting around 30-35 mpg according to the computer. I do a mixture of overtaking and careful driving but never thrash the thing. Is this about right for the 1.9 jtdm?

Last edited by Tricolori; 29-12-11 at 19:08. Reason: forgot
Tricolori is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159 , clutch , problem , tracking

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome