Vibration on idle and between 1000-1200 rpm - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 15-12-11 Thread Starter
Status: -
Join Date: Dec 2011
Location: Netherlands
County: Zuid Holland
Posts: 1

Member car:

159 JTD 16v

Vibration on idle and between 1000-1200 rpm

Hi everyone,

I have a problem with my Alfa 159 JTD 16V the when the engine is warm so above 80 Dergees on idle the engine vibrates more then when I bought the car. But when I accelerat from 750 rpm to 850 rpm not vibration, But then again from 1000 tot 1200 rpm again vibrations.

What could this be?

a couple of weeks ago I changed the gearbox because its was not good anymore and the mechanic told me that de DMF is okay, so that I don't think so could this be engine mounts?
unreal1983 is offline  
Sponsored Links
Status: -
AO Member
Join Date: Oct 2009
Location: United Kingdom
County: -
Posts: 12

Member car:

Buying 159

I have the exact same problem as you have described. Did you get a fix? If so I would appreciate any advice
polskijay is offline  
Status: 159 Cruiser and Guilietta pocket rocket
AO Silver Member
giblets46's Avatar
Join Date: Jul 2012
Location: United Kingdom
County: Warwickshire
Posts: 4,198
Any idea where the noise comes from? Engine bay, chasis etc. have you stood outside the car and tried to investigate?
giblets46 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

idle , rpm , vibration

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome