2.4 JTDm 20v - Strange Noise from Engine - Page 2 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Lucky Lui
Status: - Update
Posts: n/a
So last Monday dropped the motor off at Alfa dealer in Hemel and they gave me a lively little Mito which was fun to drive and quick enough to make me think about getting one.
Anyways, they removed EGR valve checked, cleaned and lubricated. Removed throttle body to find it blocked & manifold filled with carbon. Cleaned out and refitted and now the car runs like it should do. I'm getting better mpg and it's better to drive at low speeds. Still a bit lumpy on start up so doing a little preventative maintenence. As suggested by Sandro the engineer I'll be putting in fuel addatives to keep it clean and not using supermarket diesel but sticking with BP or Shell. The occassional Shell V-Power or BP Ultimate every 4 tanks will be nice too. I'll also drive it just a little harder not too much mind as I want to keep that mpg around the 40 mark.
Sponsored Links

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

20v , engine , jtdm , noise , strange

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome