Engine warning light - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 08-12-11 Thread Starter
Status: -
AO Member
Join Date: Jun 2011
Location: United Kingdom
County: Essex
Posts: 409
Engine warning light

Bought the TBi TI in July, new. Engine light has come on three times now. First time it was the lambda sensor; second time it needed a software download; now I have to go back in tomorrow. Getting annoying.
Even though the car drives ok with the light on, I have to travel 20miles to the dealers with time out of work each time.
Has anybody else experienced this? What could be the cause?
miketi is offline  
Sponsored Links
Status: Stealth mode.
AO Member
dcystar147's Avatar
Join Date: Oct 2006
Location: United Kingdom
County: Aberdeenshire
Posts: 417
Images: 7
Mine required a Lambda sensor connector kit to clear light. Got the ECU upgrade at same time when it was in. See :-


Not sure what else it could be after that
dcystar147 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

engine , light , warning

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome