Engine light on and off - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 04-12-11 Thread Starter
Status: -
AO Member
alfa159owner's Avatar
Join Date: Jan 2009
Location: Australia
County: Western Australia
Posts: 42

Member car:


Engine light on and off

Hey all,
I have been seeing the engine light coming on and off...
Taken it to alfa, they mentioned it was the timing chain,
the car only has 75000kms on it,,,,,,,so they have now changed the chain, and about 3 weeks after , hey presto, the light has come back on again...
the light has been on for a week now because alfa doesn't have the time to look at it...today the light has now gone off and we are cooking with gas again.....
has anyone seen this problem, i really don't believe the timing chain needed to be replaced at this low Kms.......
alfa159owner is offline  
Sponsored Links
Status: -
AO Member
Lees7's Avatar
Join Date: Oct 2011
Location: United Kingdom
County: Norfolk
Posts: 40

Member car:

Brera 2.2 sv

I had similar issue with my brera chain was changed under warranty. Light still kept doing the same it ended up being a worn sprocket. Could possibly just be a sensor though
Lees7 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

engine , light

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome