squeaking breaks - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 26-11-11 Thread Starter
Status: -
AO Member
Join Date: Oct 2011
Location: United Kingdom
County: Bedfordshire
Posts: 53
Images: 14

Member car:

Brera S

Help squeaking breaks

Hi guys,

Ive got a nasty continuous squeak form my breaks :S

This occurs when driving/accelerating (not just a normal squeak under breaking).

Ive had it looked at by Alfa (although i don't think they took it serious) and an independent garage.

Alfa said their was nothing wrong with them (i think they just looked at how worn the pads were and assumed there was nothing wrong).

My garage said there is a 'lip' on my front disks which they believe to be the cause of the squeaking and could only recommended changing the pads/discs (they said they cannot be sure this would resolve the problem but can only help). However, they did say that due to the fact a lip has occurred (and as far as I can remember they said its only on the 'inside' facing side of the disc), it should be a warranty job?

Any comments guys?

Or anyone with the same experience/is this a common problem?

I will be contacting Alfa again on Monday because this is ridiculous and should not be happening.

Thanks in advance.
Oliver Brera S is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

breaks , discs , pads , squeak , squeaking , waranty

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome