159 JTS TI manual gear problems - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 03-10-11 Thread Starter
Status: -
Join Date: Oct 2011
Location: Australia
County: Western Australia
Posts: 1

Member car:

159 jts ti

Hmmm 159 JTS TI manual gear problems

Hi all,

I've been having problems shifting down from 5th into 4th gear, the gear stick disengages and pops back to neutral. That happens when the revs are above 3,500 rpm. At lower revs it goes from 5th to 4th without problems.

Would anyone be able to guess what the problem might be?

blorenzon is offline  
Sponsored Links
Status: GOT CAMS?
AO Silver Member
BenzinaBrera's Avatar
Join Date: Aug 2010
Location: South Africa
County: Gauteng
Posts: 2,929

Member car:

Brera 3.6

have linkages checked, or gearbox oil can be low.
BenzinaBrera is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159 , gear , jts , manual , problem , problems

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome