Alfa 159 VIN Not recognized - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 27-09-11 Thread Starter
Status: -
AO Member
Join Date: Jul 2007
Location: Denmark
Posts: 19

Member car:


Alfa 159 VIN Not recognized

Hi all

I just bought a AR159 SW 1.9JTD

From the papers it is stated as a 2006 but the seller had it as 2007. I tried checking the VIN number with ePer but it says "chassis number" doesn´t exist. Anybody experienced something like that. Also when I tried checking the number on various sites they state that 10th digit may not be a zero....

Here´s the number
ZAR93900007077584, I double checked it in the enginebay (listed like this:ZAR939000*07077584).

Can anyone help please. I want to be sure before going to the dealer to complain.

Best regards
Thiele is offline  
Sponsored Links
Status: If I agreed with you, we'd both be wrong
AO Member
Elfred's Avatar
Join Date: Aug 2008
Location: United Kingdom
County: Hertfordshire
Posts: 693
Your VIn looks legit. If you e-mail it to they will send you back all the details.
Elfred is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159 , alfa , recognized , vin

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome