159 Window Washer Problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 21-09-11 Thread Starter
Status: -
AO Member
Join Date: May 2007
Posts: 70
159 Window Washer Problem

I have a 159 ti thats 11 months old.
Since I've had the car ( 4 months ) the window washers have been at best erratic.
Sometime they work, but most of the time you have to hold the washer pump on for a few minutes for it to work at full power.
I've had a look at the jets but it's hard to see if they are clean or not.

Any ideas welcome

PRJALFA is offline  
Sponsored Links
Status: -
Club Member
Membro Premio
159_kid's Avatar
Club Member Number: 1398
Join Date: Oct 2010
Location: United Kingdom
Posts: 1,848
It could be the washer motor is on its way out or u may have a hole in the hose between the washer bottle and the jets. Try using the washer parked on your drive to check for leaks
159_kid is offline  
Status: Now just the 147..
AO Silver Member
lovelyred159's Avatar
Join Date: Sep 2004
Location: United Kingdom
County: Somerset
Posts: 1,949
Images: 11

Member car:

147 1.6 Lusso

It's virtually impossible to check the jets as they are not of a type you can stick a pin in!. Sounds like a warranty job to me? I had my jets replaced under warranty, mind they still are fairly rubbish though they have not been intermittent like yours.
lovelyred159 is offline  
Status: If I agreed with you, we'd both be wrong
AO Member
Elfred's Avatar
Join Date: Aug 2008
Location: United Kingdom
County: Hertfordshire
Posts: 693
Sounds like a leak in the pipe to me as it's draining out when not being used.
Elfred is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159 , problem , washer , window

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome